Общая схема проведения исследования


Îñíîâíûå îïðåäåëåíèÿ

Основные определения

Сценарии

Сценарии (script) или макросы (macros) - это небольшие программы, предназначенные для автоматизации решаемых с помощью прикладной программы задач. Во многих прикладных программах, например в "офисных" пакетах Microsoft Office, OpenOffice и др. при обработке макроса автоматически выполняется заданная для каждого макроса последовательность действий - нажатия на клавиши, выбор пунктов меню и т. д. Предоставляется интерфейс для записи новых и перезаписи существующих макросов.

Сценарии в приложении [image] ГРАН: Колориметрия используются для совершения одинаковых действий несколько раз, используя для вызова последовательности этих действий одну команду [image] Выполнить.

Сценарий - это последовательность команд приложения, используемая для автоматического выполнения некоторых операций.

Текст сценария - это набор процедур и, при необходимости, пояснительного текста, составленный по определённым правилам.

Файл сценария с расширением "scen" - это текстовый документ, содержащий текст сценария и комментарии.

Процедура сценария - это условное обозначение некоторой команды в виде записи в тексте сценария.

Команда сценария - это действие (или последовательность действий), которое выполнит приложение в соответствии с указанной процедурой и её параметрами. Каждая команда обычно соответствует определённой команде главного меню приложения, а параметры процедуры - опциям в диалоговом окне этой команды.


Îêíî "Ðåäàêòîð ñöåíàðèåâ"

Окно "Редактор сценариев"

Сценарии > Редактор сценариев

Редактор сценариев является частью приложения [image] ГРАН: Колориметрия и работает совместно с другими модулями.

Окно [image] Редактора сценариев предназначено:

для управления файлами сценариев: создания, копирования, удаления;

запуска или выполнения сценариев;

для просмотра и редактирования текста сценария, добавления и удаления процедур, в том числе с помощью встроенного справочника.

Управление файлами сценариев осуществляется с помощью кнопок на панели инструментов. Текст сценария отображается и редактируется в отдельном текстовом поле - обычном текстовом редакторе.


Ïàíåëü èíñòðóìåíòîâ

Панель инструментов

Сценарии > Редактор сценариев

Команда | Описание
 | Создать новый пустой файл сценария. Перед созданием сценария необходимо указать имя файла с помощью стандартного диалога "Сохранить как". После создания имя файла добавляется в список сценариев и открывается для редактирования.
 | Удалить выбранный файл сценария из списка. Нажатие на стрелочную кнопку выводит меню с другими вариантами удаления.
 | Удалить сценарий из списка и удалить файл сценария в корзину.
 | Добавить файл сценария в список (с помощью стандартного диалога "Открыть") и открыть его для просмотра и редактирования.
 | Сохранить изменения в тексте сценария в файл. Нажатие на стрелочную кнопку выводит меню с другими вариантами сохранения.
 | Сохранить копию выбранного сценария под другим именем с помощью стандартного диалога "Сохранить как". Файл копии сценария будет добавлен в список и открыт для редактирования.
 | Вставить в текст сценария выбранную из справочника процедуру.
 | Выполнить команды открытого сценария.
 | Открыть данный раздел файла справки.
 | Перейти в режим справочного указателя. Открыть раздел справки по выбранному мышью элементу окна.


Ñïèñîê ñöåíàðèåâ

Список сценариев

Сценарии > Редактор сценариев

Enter topic text here.


Òåêñòîâûé ðåäàêòîð

Текстовый редактор

Сценарии > Редактор сценариев

Enter topic text here.


Ñïðàâî÷íèê ïðîöåäóð

Справочник процедур

Сценарии > Редактор сценариев

Enter topic text here.


Ñîçäàíèå íîâîãî ñöåíàðèÿ

Создание нового сценария

Сценарии > Файлы сценариев

Enter topic text here.


Äîáàâëåíèå ñöåíàðèÿ

Добавление сценария

Сценарии > Файлы сценариев

Enter topic text here.


Ñîõðàíåíèå ñöåíàðèÿ

Сохранение сценария

Сценарии > Файлы сценариев

Enter topic text here.


Óäàëåíèå ñöåíàðèÿ

Удаление сценария

Сценарии > Файлы сценариев

Enter topic text here.


Ñâîéñòâà ôàéëà

Свойства файла

Сценарии > Файлы сценариев

Enter topic text here.


Îáçîð ïðîöåäóð

Обзор процедур

Сценарии

Процедуры обработки изображений

Процедуры ввода и вывода изображений

OpenImage - Открыть изображение с помощью стандартного диалога «Открыть».

OpenImageFile - Открыть изображение из указанного файла на диске без использования дополнительных диалогов.

CloseImage - Закрыть изображение и освободить занимаемую память.

CopyImage - Копировать в буфер обмена изображение или заданную маской область изображения.

RestoreImage - Восстановить открытое изображение из файла и отменить все преобразования.

SaveImage - Сохранить преобразования открытого изображение в файл.

SaveImageAs - Сохранить копию открытого изображения под другим именем в файл c помощью стандартного диалога «Сохранить».

SaveImageAsFile - Сохранить копию открытого изображения под другим именем в указанный файл.

Процедуры управления инструментами изображения

SetPointer - Устанавливает инструмент «Указатель». Процедура без параметров.

SetRectangleMask - Устанавливает инструмент «Прямоугольная маска» для создания и редактирования масок прямоугольной формы.

SetCircleMask - Устанавливает инструмент «Круглая маска» для создания масок круглой или эллипсовидной формы.

SetPolygonMask - Устанавливает инструмент «Произвольная маска» для создания масок в форме многоугольника.

SetAutoMask - Устанавливает инструмент «Автомаска» для создания масок из областей с однородным цветом.

SetColorPicker - Устанавливает инструмент «Цвет пикселя» для определения цветовых характеристик пикселя изображения, находящегося под курсором.

SetScroll - Устанавливает инструмент «Прокрутка» для позиционирования изображения в пределах главного окна перетаскиванием мышью.

SetZoom - Устанавливает инструмент «Масштаб» для установки масштаба отображения выбранных фрагментов изображения.

Процедуры управления информационными инструментами изображения

SetQuickChart - Устанавливает инструмент «Гистограмма» для просмотра предварительной гистограммы изображения или выбранной области.

SetMagnifier - Устанавливает инструмент «Увеличение» для увеличенного просмотра выбранной области на изображения.

SetNavigator - Устанавливает инструмент «Навигатор» для определения позиции видимого на экране фрагмента относительно всего изображения.

Процедуры преобразования изображения

FilterImage - Фильтрация исходного изображения или заданной маской области.

InvertImage - Инвертирование изображения или заданной маской области. Процедура без параметров.

Palette - Преобразование палитры (количества оттенков) изображения.

Undo - Отмена последнего преобразования изображения.

UndoAll - Отмена всех преобразований изображения.

Процедуры обрезки изображения

AutoCrop - Автоматическая обрезка изображения.

CropSelection - Обрезка изображения по заданной маской области.

Процедуры настройки изображения

AdjustHSL - Настройка изображения в цветовом пространстве HSL.

AdjustHSV - Настройка изображения в цветовом пространстве HSL/HSB.

GammaCorrection - Гамма-коррекция.

Процедуры контрастирования изображения

BackgroundCorrection - Автоматическое выравнивание фона.

Stretch - Автоматическое контрастирование методом линейной растяжки гистограммы.

Equalize - Автоматическое контрастирование методом эквализации гистограммы.

AutoLevels - Автоматическая нелинейная настройка яркости.

AutoColors - Автоматический баланс цветов (выравнивание интенсивности каналов).

ContrastRGB - Линейное контрастирование (в процентах) в цветовой модели RGB.

ContrastHSL - Линейное контрастирование (в процентах) в цветовом пространстве HSL.

LocalContrast - Плавное изменение локального контраста в заданном интервале значений (с максимальным изменением контраста в средней точке).

Процедуры извлечения каналов

ExtractRGB - Извлечение каналов в цветовой модели RGB.

ExtractHSV - Извлечение каналов в цветовом пространстве HSV/HSB.

ExtractHSL - Извлечение каналов в цветовом пространстве RGB.

ExtractCMYK - Извлечение каналов в цветовой модели CMYK.

Процедуры баланса цветов

BalanceRGB - Изменить баланс интенсивности каналов в цветовой модели RGB.

BalanceHSV - Изменить баланс каналов в цветовом пространстве HSV/HSB.

BalanceHSL - Изменить баланс каналов в цветовом пространстве HSL.

Процедуры для работы с масками

Преобразование масок

ThresholdMask - Создание пороговой маски.

MaskFilter - Фильтрация маски.

MaskResize - Изменение размеров маски.

InvertMask - Инвертировать маску.

DeleteMask - Удаление маски.

Ввод и вывод масок

CopyMask - Копировать маску в стек.

PasteMask - Вставить маску из стека в изображение.

Процедуры для работы с альбомом

Преобразование альбома

Album - Создание альбома объектов, заданных маской.

DeleteAlbum - Удаление альбома объектов.

AlbumFilter - Фильтрация объектов альбома.

Настройка альбома

FitPreview - Установка масштаба для просмотра выбранных объектов альбома.

Процедуры для работы с гистограммой

Преобразование гистограммы

Histogram - Расчёт гистограммы и построение графиков.

HistogramFilter - Установка параметров фильтрации гистограммы.

HistogramType - Установка типа гистограммы.

HistogramFunction - Установка гистограммной функции.

HistogramStep - Установка шага гистограммы.

Настройка отображения гистограммы

SetChartRed - Установка отображения гистограммы красного канала.

SetChartGreen - Установка отображения гистограммы зелёного канала.

SetChartBlue - Установка отображения гистограммы синего канала.

SetChartIntensity - Установка отображения гистограммы канала яркости.

SetChartLegend - Установка отображения легенды гистограммы.

SetChartGrid - Установка отображения линий сетки.

SetChartLog - Установка логарифмической шкалы для левой оси.

SetChart100 - Установка процентного формата для нижней оси.

SetChartLines - Установка отображения гистограммы в виде линий графика.

SetChartBars - Установка отображения гистограммы в столбчатой диаграммы.

Ввод и вывод гистограммы

CopyChartBMP - Копировать гистограмму в буфер обмена в формате точечного рисунка Windows Bitmap.

CopyChartWMF - Копировать гистограмму в буфер обмена в векторном формате Windows Metafile.

CopyChartEMF - Копировать гистограмму в буфер обмена в векторном формате Enhanced Windows Metafile.

Процедуры для работы со статистикой

Расчёт статистики

Statistic - Расчёт статистики гистограммы.

Digits - Установка количества знаков в дробной части при округлении значений.

Ввод и вывод статистики

CopyStatistic - Копировать таблицу статистики в буфер обмена.

Настройка отображения статистики

SetStatRed - Установка отображения статистики красного канала.

SetStatGreen - Установка отображения статистики зелёного канала.

SetStatBlue - Установка отображения статистики синего канала.

SetStatIntensity - Установка отображения статистики канала яркости.

Вспомогательные процедуры

Управление вычислениями

Pause - Пауза в выполнении сценария.

Exit - Завершить работу приложения.

DeleteAllResults - Удаление всех результатов измерений.

AddMode - Установка режима добавления.

Вывод сообщений

Message - Вывод на экран диалогового окна с запросом.

MessagePause - Пауза в выполнении сценария с выводом на экран сообщения.


Ñîñòîÿíèå ïðèëîæåíèÿ

Состояние приложения

Сценарии

Для выполнения некоторых процедур необходимо, чтобы приложение находилось в определённом состоянии. Например, для выполнения фильтрации маски, должно быть открыто исходное изображение и задана маска. В случае, когда приложение не находится в требуемом состоянии, выполнение процедуры невозможно в виду отсутствия данных для обработки. При возникновении такой ситуации, выполнение сценария прекращается.

Основные состояния приложения:

1) Исходное изображение открыто, доступны операции:

· преобразования и фильтрации изображения;
· построение гистограммы, расчёт статистики и таблицы цветов для всего иходного изображения.

2) На исходном изображении задана маска, доступны операции:

· преобразования и фильтрации маски;
· преобразования и фильтрации области изображения, заданного маской;
· построения гистограммы, расчёт статистики и таблицы цветов для области изображения, заданного маской.

3) Создан альбом объектов

4) Выполнен расчёт гистограммы

5) Выполнен расчёт статистики

6) Выполнен расчёт таблицы цветов


CloseImage

Процедура CloseImage

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

CloseImage

Описание:

Закрыть изображение и освободить занимаемую память. Предупреждение перед закрытием изображения не выдаётся.

Параметры:

Процедура без параметров.

Пример:

CloseImage;

Состояние приложения:

Исходное изображение должно быть открыто.


CopyImage

Процедура CopyImage

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

CopyImage

Описание:

Копировать в буфер обмена изображение или заданную маской область изображения.

Параметры:

Процедура без параметров.

Пример:

CopyImage;

Состояние приложения:

Исходное изображение должно быть открыто.


OpenImage

Процедура OpenImage

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

OpenImage

Описание:

Открыть изображение с помощью стандартного диалога «Открыть»:

Увеличить

Параметры:

Процедура без параметров.

Пример:

OpenImage;

Состояние приложения:

Без ограничений.


OpenImageFile

Процедура OpenImageFile

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

OpenImageFile(FileName)

Описание:

Открыть изображение из указанного файла на диске без использования дополнительных диалогов.

Параметры:

Параметр | Описание
FileName | Полный путь и имя файла изображения, заключённые в двойные кавычки

Пример:

OpenImageFile("C:\Мои документы\Мои рисунки\Image001.jpg");

Состояние приложения:

Без ограничений.


RestoreImage

Процедура RestoreImage

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

RestoreImage

Описание:

Восстановить открытое изображение из файла и отменить все преобразования. Маска, заданная на изображении будет удалена. Предупреждение перед выполнением операции не выдаётся.

Параметры:

Процедура без параметров.

Пример:

RestoreImage;

Состояние приложения:

Исходное изображение должно быть открыто и преобразовано.


SaveImage

Процедура SaveImage

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

SaveImage

Описание:

Сохранить преобразования открытого изображение в файл.

Параметры:

Процедура без параметров.

Пример:

SaveImage;

Состояние приложения:

Исходное изображение должно быть открыто и преобразовано.


SaveImageAs

Процедура SaveImageAs

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

SaveImageAs

Описание:

Сохранить копию открытого изображения под другим именем в файл c помощью стандартного диалога «Сохранить»:

Увеличить

Параметры:

Процедура без параметров.

Пример:

SaveImageAs;

Состояние приложения:

Исходное изображение должно быть открыто.


SaveImageAsFile

Процедура SaveImageAsFile

Сценарии > Процедуры обработки изображений > Ввод и вывод изображений

Синтаксис:

SaveImageAsFile(FileName,ShowParams)

Параметры:

Параметр | Значение | Описание | Примечание
FileName |  | Полный путь и имя файла изображения, заключённые в двойные кавычки. |
ShowParams | ON | Отображать диалоговое окно дополнительных параметров сохранения изображения в файл (цвет, сжатие и т.п.) | Не используется для формата Graphic Interchange Format и при сохранении данных растра в текстовый файл. Подробнее...
 | OFF | Не отображать диалоговое окно дополнительных параметров.

Описание:

Сохранить копию открытого изображения под другим именем в указанный файл. Графический формат файла определяется по расширению файла. Допустимые расширения файлов:

Расширение | Формат
bmp | Windows Bitmap
jpg | JPEG Image
tif | Tagged Image Format
gif | Graphic Interchange Format
png | Portable Network Graphics
txt | Текстовый файл (сохранение данных растра в виде таблицы)

Диалоговое окно дополнительных параметров для изображений в формате Windows Bitmap,Tagged Image Format, Portable Network Graphics:

Диалоговое окно дополнительных параметров для изображений в формате JPEG Image:

Для формата Graphic Interchange Format дополнительных параметров сжатия, цвета и разрядности при сохранении в файл не предусмотрено .

При сохранении данных растра в виде таблицы в текстовый файл с разделителями дополнительных параметров сохранения не предусмотрено.

Пример:

SaveImageAsFile("C:\Мои документы\Мои рисунки\Image001.jpg",OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


SetPointer

Процедура SetPointer

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetPointer

Описание:

Устанавливает инструмент «Указатель» (Pointer).

Параметры:

Процедура без параметров.

Пример:

SetPointer;

Состояние приложения:

Без ограничений.


SetRectangleMask

Процедура SetRectangleMask

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetRectangleMask(State)

Описание:

Устанавливает инструмент «Прямоугольная маска» (Rectangle Selection) для создания и редактирования масок прямоугольной формы.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetRectangleMask(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetCircleMask

Процедура SetCircleMask

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetCircleMask(State)

Описание:

Устанавливает инструмент «Круглая маска» (Circle Selection) для создания масок круглой или эллипсовидной формы.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetCircleMask(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetPolygonMask

Процедура SetPolygonMask

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetPolygonMask(State)

Описание:

Устанавливает инструмент «Произвольная маска» (Polygon Selection) для создания масок в форме многоугольника.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetPolygonMask(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetAutoMask

Процедура SetAutoMask

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetAutoMask(State)

Описание:

Устанавливает инструмент «Автомаска» (Magic Wand) для создания масок из областей с однородным цветом:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetAutoMask(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetColorPicker

Процедура SetColorPicker

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetColorPicker(State)

Описание:

Устанавливает инструмент «Цвет пикселя» (Color Picker, Dropper) для определения цветовых характеристик пикселя изображения, находящегося под курсором:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetColorPicker(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetScroll

Процедура SetScroll

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetScroll(State)

Описание:

Устанавливает инструмент «Прокрутка» (Hand Scrolling) для позиционирования изображения в пределах главного окна перетаскиванием мышью.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetScroll(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetZoom

Процедура SetZoom

Сценарии > Процедуры обработки изображений > Управление инструментами изображения

Синтаксис:

SetZoom(State)

Описание:

Устанавливает инструмент «Масштаб» (Zoom) для установки масштаба отображения выбранных фрагментов изображения:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetZoom(ON);

Состояние приложения:

Исходное изображение должно быть открыто.


SetQuickChart

Процедура SetQuickChart

Сценарии > Процедуры обработки изображений > Управление информационными инструментами изображения

Синтаксис:

SetQuickChart(State)

Описание:

Устанавливает инструмент «Гистограмма» для просмотра предварительной гистограммы изображения или выбранной области:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetQuickChart(ON);

Состояние приложения:

Без ограничений.


SetMagnifier

Процедура SetMagnifier

Сценарии > Процедуры обработки изображений > Управление информационными инструментами изображения

Синтаксис:

SetMagnifier(State)

Описание:

Устанавливает инструмент «Увеличение» для увеличенного просмотра выбранной области на изображения:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetMagnifier(ON);

Состояние приложения:

Без ограничений.


SetNavigator

Процедура SetNavigator

Сценарии > Процедуры обработки изображений > Управление информационными инструментами изображения

Синтаксис:

SetNavigator(State)

Описание:

Устанавливает инструмент «Навигатор» для определения позиции видимого на экране фрагмента относительно всего изображения:

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Инструмент включен. |
 | OFF | Инструмент выключен. |

Пример:

SetNavigator(ON);

Состояние приложения:

Без ограничений.


FilterImage

Процедура FilterImage

Сценарии > Процедуры обработки изображений > Преобразование изображений

Синтаксис:

FilterImage(Method,Size,α,Count)

Описание:

Фильтрация исходного изображения или заданной маской области.

Параметры:

Параметр | Значение | Описание | Примечание
Method | 0 | Линейный усредняющий фильтр. |
 | 1 | Нелинейный медианный фильтр.
 | 2 | Усечённый усредняющий L-фильтр.
Size | 3, 5, 7, …, 25 | Размер окна. |
α | от 0 до 0.5 | Значение α для усечённого усредняющего L-фильтра. | Параметр не используется, если Method равен 0 или 1.
Count | от 1 до 10 | Количество повторов. |

Пример:

FilterImage(2,7,0.25,1);

Состояние приложения:

Исходное изображение должно быть открыто.


InvertImage

Процедура InvertImage

Сценарии > Процедуры обработки изображений > Преобразование изображений

Синтаксис:

InvertImage

Описание:

Инвертирование изображения или заданной маской области.

Параметры:

Процедура без параметров.

Пример:

InvertImage;

Состояние приложения:

Исходное изображение должно быть открыто.


Palette

Процедура Palette

Сценарии > Процедуры обработки изображений > Преобразование изображений

Синтаксис:

Palette(Size)

Описание:

Преобразование палитры (количества оттенков) изображения.

Параметры:

Параметр | Значение | Описание | Примечание
Size | от 2 до 1000 | Количество оттенков в новой палитре. |

Пример:

Palette(256);

Состояние приложения:

Исходное изображение должно быть открыто.


Undo

Процедура Undo

Сценарии > Процедуры обработки изображений > Преобразование изображений

Синтаксис:

Undo

Описание:

Отмена последнего преобразования изображения.

Параметры:

Процедура без параметров.

Пример:

Undo;

Состояние приложения:

Исходное изображение должно быть открыто и преобразовано.


UndoAll

Процедура UndoAll

Сценарии > Процедуры обработки изображений > Преобразование изображений

Синтаксис:

UndoAll

Описание:

Отмена всех преобразований изображения.

Параметры:

Процедура без параметров.

Пример:

UndoAll;

Состояние приложения:

Исходное изображение должно быть открыто и преобразовано.


AutoCrop

Процедура AutoCrop

Сценарии > Процедуры обработки изображений > Обрезка изображений

Синтаксис:

AutoCrop(Size,Frame,FrameSize)

Описание:

Автоматическая обрезка изображения.

Параметры:

Параметр | Значение | Описание | Примечание
Size | от 1 до 10000 | Минимальный габарит объектов в пикселях. |
Frame | ON | Оставить рамку (отступ от края изображения). |
 | OFF | Без рамки. |
FrameSize | от 1 до 200 | Размер рамки (отступа) в пикселях. | Параметр не используется, если Frame равен OFF.

Пример:

AutoCrop(50,ON,25);

Состояние приложения:

Исходное изображение должно быть открыто.


CropSelection

Процедура CropSelection

Сценарии > Процедуры обработки изображений > Обрезка изображений

Синтаксис:

CropSelection(Frame,FrameSize)

Описание:

Обрезка изображения по заданной маской области.

Параметры:

Параметр | Значение | Описание | Примечание
Frame | ON | Оставить рамку (отступ от края изображения). |
 | OFF | Без рамки. |
FrameSize | от 1 до 200 | Размер рамки (отступа) в пикселях. | Параметр не используется, если Frame равен OFF.

Пример:

CropSelection(ON,25);

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


AdjustHSL

Процедура AdjustHSL

Сценарии > Процедуры обработки изображений > Настройка изображений

Синтаксис:

AdjustHSL(Luminance,Contrast,Saturation)

Описание:

Настройка изображения в цветовом пространстве HSL.

Параметры:

Параметр | Значение | Описание | Примечание
Luminance | от -100 до -1 | Уменьшение яркости. |
 | 0 | Без изменения.
 | от 1 до 500 | Увеличение яркости.
Contrast | от -100 до -1 | Уменьшение контрастности. |
 | 0 | Без изменения.
 | от 1 до 100 | Увеличение контрастности.
Saturation | 0 | Без изменения. |
 | от 1 до 500 | Увеличение насыщенности.

Пример:

AdjustHSL(0,10,50);

Состояние приложения:

Исходное изображение должно быть открыто.


AdjustHSV

Процедура AdjustHSV

Сценарии > Процедуры обработки изображений > Настройка изображений

Синтаксис:

AdjustHSV(Brightness,Saturation)

Описание:

Настройка изображения в цветовом пространстве HSL/HSB.

Параметры:

Параметр | Значение | Описание | Примечание
Brightness | от 0 до 1 | Увеличение яркости, 0 – без изменения. |
Saturation | от 0 до 1 | Увеличение насыщенности, 0 – без изменения. |

Пример:

AdjustHSL(0.25,0.1);

Состояние приложения:

Исходное изображение должно быть открыто.


GammaCorrection

Процедура GammaCorrection

Сценарии > Процедуры обработки изображений > Настройка изображений

Синтаксис:

GammaCorrection(Gamma,Red,Green,Blue)

Описание:

Гамма-коррекция.

Параметры:

Параметр | Значение | Описание | Примечание
Gamma | от 0.1 до 10 | Значение гаммы. 1 - Без изменения. |
Red | ON | Выполнять обработку красного канала. |
 | OFF | Не выполнять обработку красного канала.
Green | ON | Выполнять обработку зелёного канала. |
 | OFF | Не выполнять обработку зелёного канала.
Blue | ON | Выполнять обработку синего канала. |
 | OFF | Не выполнять обработку синего канала.

Пример:

GammaCorrection(1.25,ON,ON,ON);

Состояние приложения:

Исходное изображение должно быть открыто.


BackgroundCorrection

Процедура BackgroundCorrection

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

BackgroundCorrection

Описание:

Автоматическое выравнивание фона.

Параметры:

Процедура без параметров.

Пример:

BackgroundCorrection;

Состояние приложения:

Исходное изображение должно быть открыто.


Stretch

Процедура Stretch

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

Stretch

Описание:

Автоматическое контрастирование методом линейной растяжки гистограммы.

Параметры:

Процедура без параметров.

Пример:

Stretch;

Состояние приложения:

Исходное изображение должно быть открыто.


Equalize

Процедура Equalize

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

Equalize

Описание:

Автоматическое контрастирование методом эквализации гистограммы.

Параметры:

Процедура без параметров.

Пример:

Equalize;

Состояние приложения:

Исходное изображение должно быть открыто.


AutoLevels

Процедура AutoLevels

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

AutoLevels

Описание:

Автоматическая нелинейная настройка яркости.

Параметры:

Процедура без параметров.

Пример:

AutoLevels;

Состояние приложения:

Исходное изображение должно быть открыто.


AutoColors

Процедура AutoColors

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

AutoColors

Описание:

Автоматический баланс цветов (выравнивание интенсивности каналов).

Параметры:

Процедура без параметров.

Пример:

AutoColors;

Состояние приложения:

Исходное изображение должно быть открыто.


ContrastRGB

Процедура ContrastRGB

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

ContrastRGB(Value)

Описание:

Линейное контрастирование (в процентах) в цветовой модели RGB.

Параметры:

Параметр | Значение | Описание | Примечание
Value | от -100 до -1 | Увеличить контраст на значение Value. |
 | 0 | Без изменения.
 | от 1 до 100 | Уменьшить контраст на значение Value.

Пример:

ContrastRGB(-10);

Состояние приложения:

Исходное изображение должно быть открыто.


ContrastHSL

Процедура ContrastHSL

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

ContrastHSL(Value)

Описание:

Линейное контрастирование (в процентах) в цветовом пространстве HSL.

Параметры:

Параметр | Значение | Описание | Примечание
Value | 0 | Без изменения. |
 | от 1 до 100 | Увеличить контраст на значение Value.

Пример:

ContrastRGB(10);

Состояние приложения:

Исходное изображение должно быть открыто.


LocalContrast

Процедура LocalContrast

Сценарии > Процедуры обработки изображений > Контрастирование изображений

Синтаксис:

LocalContrast(Min,Max,Value,RGB)

Описание:

Плавное изменение локального контраста от Min до Max (с максимальным изменением контраста в средней точке) на значение Value.

Параметры:

Параметр | Значение | Описание | Примечание
Min | от 0 до 255 | Нижний предел. |
Max | от 0 до 255 | Верхний предел. |
Value | от -255 до -1 | Уменьшить контраст на значение Value. |
 | 0 | Без изменения.
 | от 1 до 255 | Увеличить контраст на значение Value.
RGB | ON | Выполнять обработку в каждом канале отдельно. |
 | OFF | Выполнять обработку в канале яркости.

Пример:

LocalContrast(50,200,25,OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


ExtractRGB

Процедура ExtractRGB

Сценарии > Процедуры обработки изображений > Извлечение каналов

Синтаксис:

ExtractRGB(Band,Mono,Invert)

Описание:

Извлечение каналов в цветовой модели RGB.

Параметры:

Параметр | Значение | Описание | Примечание
Band | 0 | Извлечение красного (Red) канала. | Хроматический канал.
 | 1 | Извлечение зелёного (Green) канала.
 | 2 | Извлечение синего (Blue) канала.
 | 3 | Извлечение канала яркости (Intensity). | Монохромный канал.
Mono | ON | Преобразовать в монохромный канал. | Параметр не используется для канала яркости (Band равен 3).
 | OFF | Без изменений.
Invert | ON | Инвертировать извлечённый канал. |
 | OFF | Без изменения.

Пример:

ExtractRGB(3,ON,OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


ExtractHSV

Процедура ExtractHSV

Сценарии > Процедуры обработки изображений > Извлечение каналов

Синтаксис:

ExtractHSV(Band,Mono,Invert)

Описание:

Извлечение каналов в цветовом пространстве HSV/HSB.

Параметры:

Параметр | Значение | Описание | Примечание
Band | 0 | Извлечение канала тона (Hue). | Хроматический канал.
 | 1 | Извлечение канала насыщенности (Saturation). | Монохромный канал
 | 2 | Извлечение канала яркости (Value).
Mono | ON | Преобразовать в монохромный канал. | Параметр не используется для монохромных каналов (Band равен 1 или 2).
 | OFF | Без изменений.
Invert | ON | Инвертировать извлечённый канал. |
 | OFF | Без изменения.

Пример:

ExtractHSV(0,OFF,OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


ExtractHSL

Процедура ExtractHSL

Сценарии > Процедуры обработки изображений > Извлечение каналов

Синтаксис:

ExtractHSL(Band,Mono,Invert)

Описание:

Извлечение каналов в цветовом пространстве HSL.

Параметры:

Параметр | Значение | Описание | Примечание
Band | 0 | Извлечение канала тона (Hue). | Хроматический канал.
 | 1 | Извлечение канала насыщенности (Saturation). | Монохромный канал
 | 2 | Извлечение канала яркости (Luminance).
Mono | ON | Преобразовать в монохромный канал. | Параметр не используется для монохромных каналов (Band равен 1 или 2).
 | OFF | Без изменений.
Invert | ON | Инвертировать извлечённый канал. |
 | OFF | Без изменения.

Пример:

ExtractHSL(0,OFF,OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


ExtractCMYK

Процедура ExtractCMYK

Сценарии > Процедуры обработки изображений > Извлечение каналов

Синтаксис:

ExtractCMYK(Band,Invert)

Описание:

Извлечение каналов в цветовой модели CMYK.

Параметры:

Параметр | Значение | Описание | Примечание
Band | 0 | Извлечение голубого (Cyan) канала. | Монохромный канал.
 | 1 | Извлечение пурпурного (Magenta) канала.
 | 2 | Извлечение жёлтого (Yellow) канала.
 | 3 | Извлечение чёрного (Black) канала.
Invert | ON | Инвертировать извлечённый канал. |
 | OFF | Без изменения.

Пример:

ExtractCMYK(3,OFF);

Состояние приложения:

Исходное изображение должно быть открыто.


BalanceRGB

Процедура BalanceRGB

Сценарии > Процедуры обработки изображений > Баланс цветов

Синтаксис:

BalanceRGB(R,G,B)

Описание:

Изменить баланс интенсивности каналов в цветовой модели RGB.

Параметры:

Параметр | Значение | Описание | Примечание
R | от -255 до -1 | Уменьшить интенсивность красного канала на значение R. |
 | 0 | Без изменения.
 | от 1 до 255 | Увеличить интенсивность красного канала на значение R.
G | от -255 до -1 | Уменьшить интенсивность зелёного канала на значение G. |
 | 0 | Без изменения.
 | от 1 до 255 | Увеличить интенсивность зелёного канала на значение G.
B | от -255 до -1 | Уменьшить интенсивность синего канала на значение B. |
 | 0 | Без изменения.
 | от 1 до 255 | Увеличить интенсивность синего канала на значение B.

Пример:

BalanceRGB(-10,100,0);

Состояние приложения:

Исходное изображение должно быть открыто.


BalanceHSV

Процедура BalanceHSV

Сценарии > Процедуры обработки изображений > Баланс цветов

Синтаксис:

BalanceHSV(H,S,V)

Описание:

Изменить баланс каналов в цветовом пространстве HSV/HSB.

Параметры:

Параметр | Значение | Описание | Примечание
H | 0 | Без изменения. |
 | от -180° до -1° от 1° до 180° | Сдвиг тона (Hue) в градусах на значение H.
S | от -100 до -1 | Уменьшить насыщенность (Saturation) в процентах на значение S. |
 | 0 | Без изменения.
 | от 1 до 100 | Увеличить насыщенность (Saturation) в процентах на значение S.
V | от -100 до -1 | Уменьшить яркость (Value) в процентах на V. |
 | 0 | Без изменения.
 | от 1 до 100 | Увеличить яркость (Value) в процентах на V.

Пример:

BalanceHSV(90,50,-10);

Состояние приложения:

Исходное изображение должно быть открыто.


BalanceHSL

Процедура BalanceHSL

Сценарии > Процедуры обработки изображений > Баланс цветов

Синтаксис:

BalanceHSL(H,S,L)

Описание:

Изменить баланс каналов в цветовом пространстве HSL.

Параметры:

Параметр | Значение | Описание | Примечание
H | 0 | Без изменения. |
 | от -180° до -1° от 1° до 180° | Сдвиг тона (Hue) в градусах на значение H.
S | от -100 до -1 | Уменьшить насыщенность (Saturation) в процентах на значение S. |
 | 0 | Без изменения.
 | от 1 до 100 | Увеличить насыщенность (Saturation) в процентах на значение S.
L | от -100 до -1 | Уменьшить яркость (Luminance) в процентах на значение L. |
 | 0 | Без изменения.
 | от 1 до 100 | Увеличить яркость (Luminance) в процентах на значение L.

Пример:

BalanceHSL(90,50,-10);

Состояние приложения:

Исходное изображение должно быть открыто.


ThresholdMask

Процедура ThresholdMask

Сценарии > Процедуры для работы с масками > Преобразование масок

Синтаксис:

ThresholdMask(Method,Band,Side,Smooth,Threshold)

Описание:

Создание пороговой маски гистограммным методом или по значению, заданному пользователем.

Параметры:

Параметр | Значение | Описание | Примечание
Method | 0 | В качестве порога используется значение Threshold, установленное пользователем. |
 | 1 | Автоматическое определение порога методом локального минимума. | Параметр Threshold не используется.
 | 2 | Автоматическое определение порога методом оптимального уровня.
 | 3 | Автоматическое определение порога методом максимума энтропии.
Band | 0 | Определение порога в канале яркости (Intensity). | Канал, в котором определяется пороговый уровень интенсивности.
 | 1 | Определение порога в красном (Red) канале.
 | 2 | Определение порога в зелёном (Green) канале.
 | 3 | Определение порога в синем (Blue) канале.
Side | 0 | Область определения порога – снаружи маски. | Параметр Side используется, если на изображении задана маска.
 | 1 | Область определения порога – внутри маски.
Smooth | 0 | Без фильтрации гистограммы. | Устанавливает параметры фильтрации при автоматическом определении порогового уровня, не используется, если Method равен 0
 | 3, 5, 7, …, 25 | Размер окна сглаживающего фильтра гистограммы.
Threshold | от 0 до 255 | Пороговое значение интенсивности в канале Band. | Параметр Threshold не используется, если Method равен 1, 2 или 3.

Пример:

Создание пороговой маски методом локального минимума в канале яркости, область определения – внутри маски (если маска задана), с применением сглаживающего фильтра гистограммы (размер окна 7):

ThresholdMask(1,0,1,7,128);

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


MaskFilter

Процедура MaskFilter

Сценарии > Процедуры для работы с масками > Преобразование масок

Синтаксис:

MaskFilter(Objects,Closing,Min,Max,Size,Rate,Outside,Inside)

Описание:

Фильтрация маски для удаления мелких неровностей, мелких объектов и отдельных пикселей внутри и снаружи маски.

Параметры:

Параметр | Значение | Описание | Примечание
Objects | ON | Распознавать объекты, заданные маской. |
 | OFF | Не распознавать объекты. |
Closing | ON | Закрыть маску (удалять отверстия внутри маски). | Параметры не используются, если Objects равен OFF.
 | OFF | Не закрывать маску.
Min | от 1 | Минимальный габарит (длина, высота) объектов.
Max | от 1 | Максимальный габарит (длина, высота) объектов.
Size | от 1 до 4 | Размер фильтра. | Параметры не используются, если Outside и Inside одновременно равны OFF.
Rate | от 1 до 50 | Интенсивность фильтрации.
Outside | ON | Выполнять фильтрацию снаружи маски. |
 | OFF | Не выполнять фильтрацию снаружи маски.
Inside | ON | Выполнять фильтрацию внутри маски. |
 | OFF | Не выполнять фильтрацию внутри маски.

Пример:

MaskFilter(ON,ON,25,10000,4,10,ON,OFF);

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


MaskResize

Процедура MaskResize

Сценарии > Процедуры для работы с масками > Преобразование масок

Синтаксис:

MaskResize(Size,Rate,Side)

Описание:

Изменение размеров маски.

Параметры:

Параметр | Значение | Описание | Примечание
Size | от 1 до 25 | Ширина в пикселях. |
Rate | от 1 до 4 | Интенсивность изменения размера. |
Side | 0 | Уменьшить маску (сужение к центру). |
 | 1 | Увеличить маску (расширить от центра).

Пример:

MaskResize(5,3,0);

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


InvertMask

Процедура InvertMask

Сценарии > Процедуры для работы с масками > Преобразование масок

Синтаксис:

InvertMask

Описание:

Инвертировать маску.

Параметры:

Процедура без параметров.

Пример:

InvertMask;

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


DeleteMask

Процедура DeleteMask

Сценарии > Процедуры для работы с масками > Преобразование масок

Синтаксис:

DeleteMask

Описание:

Удаление маски (без возможности отмены).

Параметры:

Процедура без параметров.

Пример:

DeleteMask;

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


CopyMask

Процедура CopyMask

Сценарии > Процедуры для работы с масками > Ввод и вывод масок

Синтаксис:

CopyMask

Описание:

Копировать маску в стек.

Параметры:

Процедура без параметров.

Пример:

CopyMask;

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


PasteMask

Процедура PasteMask

Сценарии > Процедуры для работы с масками > Ввод и вывод масок

Синтаксис:

PasteMask

Описание:

Вставить маску из стека в изображение.

Параметры:

Процедура без параметров.

Пример:

PasteMask;

Состояние приложения:

Изображение должно быть открыто.


Album

Процедура Album

Сценарии > Процедуры для работы с альбомом > Преобразование альбома

Синтаксис:

Album

Описание:

Создание альбома объектов, заданных маской.

Параметры:

Процедура без параметров.

Пример:

Album;

Состояние приложения:

Исходное изображение должно быть открыто, на изображении задана маска.


DeleteAlbum

Процедура DeleteAlbum

Сценарии > Процедуры для работы с альбомом > Преобразование альбома

Синтаксис:

DeleteAlbum

Описание:

Удаление альбома объектов.

Параметры:

Процедура без параметров.

Пример:

DeleteAlbum;

Состояние приложения:

Альбом объектов должен быть создан.


AlbumFilter

Процедура AlbumFilter

Сценарии > Процедуры для работы с альбомом > Преобразование альбома

Синтаксис:

AlbumFilter

Описание:

Фильтрация альбома. Удаление из альбома миниатюр объектов отличающихся по цвету, размерам, форме и характеру текстуры. Удалённые объекты перемещаются в "Корзину".

Параметры:

Процедура без параметров.

Пример:

AlbumFilter;

Состояние приложения:

Альбом объектов должен быть создан.


FitPreview

Процедура FitPreview

Сценарии > Процедуры для работы с альбомом > Настройка альбома

Синтаксис:

FitPreview(State)

Описание:

Установка масштаба для просмотра выбранных объектов альбома.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Установить масштаб по размеру окна. |
 | OFF | Установить масштаб 100%. |

Пример:

FitPreview(ON);

Состояние приложения:

Без ограничений.


Histogram

Процедура Histogram

Сценарии > Процедуры для работы с гистограммой > Преобразование гистограммы

Синтаксис:

Histogram

Описание:

Расчет гистограммы и построение графиков.

Параметры:

Процедура без параметров.

Пример:

Histogram;

Состояние приложения:

Исходное изображение должно быть открыто.


HistogramFilter

Процедура HistogramFilter

Сценарии > Процедуры для работы с гистограммой > Преобразование гистограммы

Синтаксис:

HistogramFilter(Method,Size,α)

Описание:

Установка параметров фильтрации гистограммы.

Параметры:

Параметр | Значение | Описание | Примечание
Method | 0 | Без фильтрации. |
 | 1 | Лилейный усредняющий фильтр. |
 | 2 | Нелинейный медианный фильтр. |
 | 3 | Усечённый усредняющий L-фильтр. |
Size | 3, 5, 7, …, 25 | Размер окна. | Параметр не используется, если Method равен 0.
α | от 0 до 0.5 | Значение для усеченного усредняющего L-фильтра. | Параметр не используется, если Method равен 0, 1 или 2.

Пример:

HistogramFilter(3,9,0.3);

Состояние приложения:

Без ограничений.


HistogramType

Процедура HistogramType

Сценарии > Процедуры для работы с гистограммой > Преобразование гистограммы

Синтаксис:

HistogramType(Type)

Описание:

Установка типа гистограммы.

Параметры:

Параметр | Значение | Описание | Примечание
Type | 0 | Линейная гистограмма. |
 | 1 | Кумулятивная гистограмма.

Пример:

HistogramType(0);

Состояние приложения:

Без ограничений.


HistogramFunction

Процедура HistogramFunction

Сценарии > Процедуры для работы с гистограммой > Преобразование гистограммы

Синтаксис:

HistogramFunction(Function)

Описание:

Установка гистограммной функции. Для функции вероятности устанавливается процентный формат для левой оси (логарифмическая шкала недоступна).

Параметры:

Параметр | Значение | Описание | Примечание
Function | 0 | Функция плотности. |
 | 1 | Функция вероятности.

Пример:

HistogramFunction(0);

Состояние приложения:

Без ограничений.


HistogramStep

Процедура HistogramStep

Сценарии > Процедуры для работы с гистограммой > Преобразование гистограммы

Синтаксис:

HistogramStep(Step)

Описание:

Установка шага гистограммы (количества значений в интервале).

Параметры:

Параметр | Значение | Описание | Примечание
Step | от 1 до 100 | Шаг гистограммы. |

Пример:

HistogramStep(5);

Состояние приложения:

Без ограничений.


SetChartRed

Процедура SetChartRed

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartRed(State)

Описание:

Установка отображения гистограммы красного канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать гистограмму красного канала. |
 | OFF | Не отображать гистограмму красного канала.

Пример:

SetChartRed(ON);

Состояние приложения:

Без ограничений.


SetChartGreen

Процедура SetChartGreen

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartGreen(State)

Описание:

Установка отображения гистограммы зелёного канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать гистограмму зелёного канала. |
 | OFF | Не отображать гистограмму зелёного канала.

Пример:

SetChartGreen(ON);

Состояние приложения:

Без ограничений.


SetChartBlue

Процедура SetChartBlue

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartBlue(State)

Описание:

Установка отображения гистограммы синего канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать гистограмму синего канала. |
 | OFF | Не отображать гистограмму синего канала.

Пример:

SetChartBlue(ON);

Состояние приложения:

Без ограничений.


SetChartIntensity

Процедура SetChartIntensity

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartIntensity(State)

Описание:

Установка отображения гистограммы канала яркости.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать гистограмму канала яркости. |
 | OFF | Не отображать гистограмму канала яркости.

Пример:

SetChartIntensity(ON);

Состояние приложения:

Без ограничений.


SetChartLegend

Процедура SetChartLegend

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartLegend(State)

Описание:

Установка отображения легенды гистограммы.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать легенду. |
 | OFF | Не отображать легенду.

Пример:

SetChartLegend(OFF);

Состояние приложения:

Без ограничений.


SetChartGrid

Процедура SetChartGrid

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartGrid(State)

Описание:

Установка отображения линий сетки.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать сетку. |
 | OFF | Не отображать сетку.

Пример:

SetChartGrid(ON);

Состояние приложения:

Без ограничений.


SetChartLog

Процедура SetChartLog

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartLog(State)

Описание:

Установка логарифмической шкалы для левой оси. Логарифмическая шкала доступна только для функции плотности. Для функции вероятности логарифмическая шкала автоматически отключается.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Логарифмическая шкала. |
 | OFF | Обычная шкала.

Пример:

SetChartLog(ON);

Состояние приложения:

Без ограничений.


SetChart100

Процедура SetChart100

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChart100(State)

Описание:

Установка процентного формата для нижней оси.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Процентный формат для нижней оси (от 1 до 100%). |
 | OFF | Обычная шкала интенсивности (от 0 до 255).

Пример:

SetChart100(ON);

Состояние приложения:

Без ограничений.


SetChartLines

Процедура SetChartLines

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartLines

Описание:

Установка отображения гистограммы в виде линий графика.

Параметры:

Процедура без параметров.

Пример:

SetChartLines;

Состояние приложения:

Без ограничений.


SetChartBars

Процедура SetChartBars

Сценарии > Процедуры для работы с гистограммой > Настройка отображения гистограммы

Синтаксис:

SetChartBars

Описание:

Установка отображения гистограммы в столбчатой диаграммы.

Параметры:

Процедура без параметров.

Пример:

SetChartBars;

Состояние приложения:

Без ограничений.


CopyChartBMP

Процедура CopyChartBMP

Сценарии > Процедуры для работы с гистограммой > Ввод и вывод гистограмм

Синтаксис:

CopyChartBMP

Описание:

Копировать гистограмму в буфер обмена в формате точечного рисунка Windows Bitmap.

Параметры:

Процедура без параметров.

Пример:

CopyChartBMP;

Состояние приложения:

Выполнен расчёт гистограммы.


CopyChartWMF

Процедура CopyChartWMF

Сценарии > Процедуры для работы с гистограммой > Ввод и вывод гистограмм

Синтаксис:

CopyChartBMP

Описание:

Копировать гистограмму в буфер обмена в векторном формате Windows Metafile.

Параметры:

Процедура без параметров.

Пример:

CopyChartWMF;

Состояние приложения:

Выполнен расчёт гистограммы.


CopyChartEMF

Процедура CopyChartEMF

Сценарии > Процедуры для работы с гистограммой > Ввод и вывод гистограмм

Синтаксис:

CopyChartEMF

Описание:

Копировать гистограмму в буфер обмена в векторном формате Enhanced Windows Metafile.

Параметры:

Процедура без параметров.

Пример:

CopyChartEMF;

Состояние приложения:

Выполнен расчёт гистограммы.


Statistic

Процедура Statistic

Сценарии > Процедуры работы со статистикой > Рсчёт статистики

Синтаксис:

Statistic

Описание:

Расчет статистики гистограммы.

Параметры:

Процедура без параметров.

Пример:

Statistic;

Состояние приложения:

Выполнен расчёт гистограммы.


Digits

Процедура Digits

Сценарии > Процедуры работы со статистикой > Рсчёт статистики

Синтаксис:

Digits(Value)

Описание:

Установка количества знаков в дробной части при округлении значений.

Параметры:

Параметр | Значение | Описание | Примечание
Value | от 1 до 10 | Количество знаков в дробной части. |

Пример:

Digits(5);

Состояние приложения:

Без ограничений.


CopyStatistic

Процедура CopyStatistic

Сценарии > Процедуры работы со статистикой > Ввод и вывод статистики

Синтаксис:

CopyStatistic

Описание:

Копировать таблицу статистики в буфер обмена.

Параметры:

Процедура без параметров.

Пример:

CopyStatistic;

Состояние приложения:

Выполнен расчёт статистики.


SetStatRed

Процедура SetStatRed

Сценарии > Процедуры работы со статистикой > Настройка отображения статистики

Синтаксис:

SetStatRed(State)

Описание:

Установка отображения статистики красного канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать статистику красного канала. |
 | OFF | Не отображать статистику красного канала.

Пример:

SetStatRed(ON);

Состояние приложения:

Без ограничений.


SetStatGreen

Процедура SetStatGreen

Сценарии > Процедуры работы со статистикой > Настройка отображения статистики

Синтаксис:

SetStatGreen(State)

Описание:

Установка отображения статистики зелёного канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать статистику зелёного канала. |
 | OFF | Не отображать статистику зелёного канала.

Пример:

SetStatGreen(ON);

Состояние приложения:

Без ограничений.


SetStatBlue

Процедура SetStatBlue

Сценарии > Процедуры работы со статистикой > Настройка отображения статистики

Синтаксис:

SetStatBlue(State)

Описание:

Установка отображения статистики синего канала.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать статистику синего канала. |
 | OFF | Не отображать статистику синего канала.

Пример:

SetStatBlue(ON);

Состояние приложения:

Без ограничений.


SetStatIntensity

Процедура SetStatIntensity

Сценарии > Процедуры работы со статистикой > Настройка отображения статистики

Синтаксис:

SetStatIntensity(State)

Описание:

Установка отображения статистики канала яркости.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Отображать статистику канала яркости. |
 | OFF | Не отображать статистику канала яркости.

Пример:

SetStatIntensity(ON);

Состояние приложения:

Без ограничений.


Exit

Процедура Exit

Сценарии > Вспомогательные процедуры > Управление вычислениями

Синтаксис:

Exit

Описание:

Завершить работу приложения. Предупреждение перед выходом из программы не выдаётся!

Параметры:

Процедура без параметров.

Пример:

Exit;

Состояние приложения:

Без ограничений.


Pause

Процедура Pause

Сценарии > Вспомогательные процедуры > Управление вычислениями

Синтаксис:

Pause(Time)

Описание:

Пауза в выполнении сценария.

Параметры:

Параметр | Значение | Описание | Примечание
Time | от 0 до 60 | Задержка в секундах. |

Пример:

Pause(2.5);

Состояние приложения:

Без ограничений.


DeleteAllResults

Процедура DeleteAllResults

Сценарии > Вспомогательные процедуры > Управление вычислениями

Синтаксис:

DeleteAllResults

Описание:

Удаление всех результатов измерений (гистограмма, статистика, альбом, таблицы цветов).

Параметры:

Процедура без параметров.

Пример:

DeleteAllResults;

Состояние приложения:

Без ограничений.


AddMode

Процедура AddMode

Сценарии > Вспомогательные процедуры > Управление вычислениями

Синтаксис:

AddMode(State)

Описание:

Управление режимом добавления. В режиме добавления результаты текущего измерения объединяются с результатами предыдущего измерения, таким образом происходит накопление результатов.

Параметры:

Параметр | Значение | Описание | Примечание
State | ON | Включить режим добавления. |
 | OFF | Выключить режим добавления. |

Пример:

AddMode(ON);

Состояние приложения:

Без ограничений.


Message

Процедура Message

Сценарии > Вспомогательные процедуры > Вывод сообщений

Синтаксис:

Message(Text)

Описание:

Вывод на экран диалогового окна с запросом:

Выполнение сценария продолжится, если пользователь нажмёт кнопку «ОК». Если будет нажата кнопка «Отмена» – выполнение сценария прерывается.

Параметры:

Параметр | Значение | Описание | Примечание
Text |  | Произвольный текст сообщения, заключённый в двойные кавычки. |

Пример:

Message("Продолжить?");

Состояние приложения:

Без ограничений.


MessagePause

Процедура MessagePause

Сценарии > Вспомогательные процедуры > Вывод сообщений

Синтаксис:

MessagePause(Text,Time)

Описание:

Пауза в выполнении сценария с выводом на экран сообщения:

Выполнение сценария продолжится после заданного времени.

Параметры:

Параметр | Значение | Описание | Примечание
Text |  | Произвольный текст сообщения, заключенный в двойные кавычки. |
Time | от 0 до 60 | Задержка в секундах. |

Пример:

MessagePause("Подождите...",10);

Состояние приложения:

Без ограничений.


Âîïðîñû áåçîïàñíîñòè

Вопросы безопасности работы со сценариями

Сценарии

Перед работой со сценариями в ознакомительных целях или в процессе обучения, рекомендуется создавать резервные копии всех важных исходных данных перед внесением изменений в файлы сценариев и файлы изображений.

При работе со сценариями рекомендуется соблюдать осторожность, так как некоторые команды могут:

изменять настройки приложения;

изменять параметры отображения графиков, таблиц, данных;

вносить изменения в файлы.

Неправильно составленный сценарий может вызвать исключительную ситуацию в работе приложения и аварийный выход из программы. Некорректно используемые операции ввода и вывода, открытия и сохранения файлов могут серьезно повредить систему.